Issue during install of erpnext in ubunut 16.04


I am getting below error when i runt this command in my local system ubuntu 16.04

Command “python egg_info” failed with error code 1 in /tmp/pip-build-wr7yp7/mysql-python/


This thread should help and specifically point 18 - 21

Thank you !

I follow all step

now I am getting below error
2017-05-02 12:08:50 [20447] [ERROR] Procfile does not exist or is not a file


Are you running the bench commands from the frappe-bench folder/directory?


I am running this command “bench start” in frappe-bench folder/directory

Run this command bench setup procfile

Thank you.

This command run properly.

Can you give me list of step need follow after this command.

bench start

What is next step.

I run url in browser but its no loading

Where are you running ERPNext from? VM, Cloud, Bitnami?

From my loacal system.

Ubuntu 16.04

Did you setup in production or developer mode?
Got to http://localhost or–> What do you get
Try and → What do you get ?

What messages are you getting in the console/terminal after you run bench start

Below message show me after run bench start.

Run the following:

bench setup socketio 
bench setup redis
bench restart

Then reboot your computer

After running bench setup socketio

getting below message

npm WARN enoent ENOENT: no such file or directory, open
npm WARN frappe-bench No description
npm WARN frappe-bench No repository field.
npm WARN frappe-bench No README data
npm WARN frappe-bench No license field.

Then I run bench setup redis
Then bench start

show me below message

[sudo] password for serpentcs:
INFO:bench.utils:sudo supervisorctl restart frappe:
frappe: ERROR (no such group)
frappe: ERROR (no such group)

Reboot your computer than bench start

I Reboot my computer than bench start

it show me below message then I run
its not laoding

Seems like you are having memory issues. Judging from the trace, ERPNext is installed properly already but your memory issue is preventing it from running redis. You need to resolve that before you can proceed further.

Is there any solution ?
How can I remove it from my system ? after remove properly I will try again.

Google it or find a system admin …