Issue in sending emails

i have issue when i send email, it will not really not sent (also backup file email not sending)

But when i go to email queue and click on Send Now Button, it will send mail immediately

Any changes need in setting ? any solution ?

Hi @nilpatel42,

Please check it.

From the frappe config, the scheduler runs a task called every 60 seconds. You can find more information about this in the link provided: Background Jobs.

Hope this information is useful to you.

Thank You!

As per my observation and experience, by default, every 2 minutes, the system tries to pick and try to send emails from the email queue. Did you wait and check?


i have RQ Job Scheduler Inactive


i tried running bench --site all enable-scheduler
not working

also i wait for more than 10 minutes but not sending

RQ Worker Satus

Thank You

Please apply it.

bench --site enable-scheduler

// OR

bench --site scheduler enable
bench --site scheduler resume

Thank You!

1 Like

Thank @NCP

It’s Working

one question, i have production server, can i reduce interval of sending email ?

Hi @nilpatel42,

I already send the thread in this post. so please explore it. Also, I know your future ideas :sweat_smile:

Thank You!

Thank @NCP

this post have solution, but making changes in backend in production server is okay ?

No, we are not suggesting changes in the core. If you want then please override this thing using the custom app or some server script logic.

Thank You!