Issue with fresh installation of develop version


I tried following these steps to install a fresh version of ERPNext Develop. I need the develop version for developing apps:

sudo python --develop

I am getting the following error:
Traceback (most recent call last):
File “”, line 342, in
File “”, line 108, in install_bench
run_playbook(‘develop/install.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 292, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/”, line 540, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘develop/install.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=umag’]’ returned non-zero exit status 2

Also, I had a version of ERPNEXT on my local desktop and when I had tried to run a bench update, it said that it was pointing to develop which was not existing or something like that. So, I had to go for a fresh installation. Please help.


Are you installing over your old installation?

No, I deleted the bench-repo and frappe-bench folders and also removed the databases before trying to do the install.

  • are you stop nginx and mysql before you install?
  • are you update your nodejs and your python?
  • are you uninstall mariadb or mysql ?
  • are you remove folder frappe-bench and bench repo?

I was able to resolve this issue. I went back to the old method of installation by using

sudo bash

and it worked. Don’t know why the new commands were not working.


can i ask you? what is your erpnext and ubuntu current version?

i think,
in old method use “” and in new method use “” (python 27).