Issue with Workflow

Hi there,
I have created a workflow for approval of Leave Application.

I have a user who has a role of leave approver and another user who has a role of HOD.
The workflow is such that:-
Employee applies for leave application and Leave approver approves it so that HOD can provide further approval.
But the problem i am facing is quite strange:
Employee applied for a leave and leave approver tries to approve it but gives an error no permission to save leave application when i try to click on Approve again it bypasses the HOD Approval and sets the state to Approved by hod state.
Idk Why such issue.
Can you guys help me out with this?

I ll paste the screen shot of my workflow:


Check if user Leave Approver has permissions to save the leave application.


Please how do you check for this?i am having the exact same error.

@Ujjawal …please were you able to resolve this issue?how did you achieve it?

@bola . Type Role Permission Manager in the awesome bar and check if the user has permissions to save the leave application .


@muthu Thanks alot for your response i have already done this but the error still persists…please help!!

I still have the same error, i have given leave approver the permissions you specified.