Item Data Import stuck in Uploading

Tried to upload a single record in item and import tool is stuck in “Uploading…” Can anyone help? Thanks!

Are you using the latest version of ERPNext?

Yes. I also tried to upload new item in my 30-day trial account and i get the same behavior.

Using VM:
ERPNext: v5.7.7
Frappe Framework: v6.0.7

Here is the file i tried to upload.

@airzoink For some reason, async is not setup correctly.


bench --site yoursite set-config disable_async True

And run again.

May i know what “yoursite” should be? Can you give an example? Thanks!

@rmehta I’m facing the same issue as well. I have tried disabling async - I’m trying to upload just 5 salary structures and yet it hangs…

@airzoink - yoursite by defaullt is site1.local, if you had only one site and didnt change it during install.

@rmehta got it resolverd…it was a problem with MS Excel 2013 - when I saved the csv file with data, it removed double quotes for empty columns - which made the file non-readable by ERPNext. I edited the file using a text editor and it uploaded fine.

I am facing the same issue. Sometimes it works, sometimes not.

Yeah async is not stable at the moment, we are removing async for data import in the next release.


What were your edits exactly?

Mine is still stuck on uploading and I did everything suggested on this thread

@Johannes_Maepa In my case, the problem was with MS Excel. I didn’t have async issues as mentioned above. So, it was just a matter of using a different editing software like notepad to change the data and upload worked.

I got it right. I was using OpenCalc and the problem was that it was adding semi-colons as delimiters. I need to upload 7277 records. You can imagine the stress I was having

I have similar issue with the versions

ERPNext: v10.1.54 (master)
ERPNext Shopify: v2.0.26 (develop)
Frappe Framework: v10.1.49 (master)

When trying to upload a csv file of items (even only one test item):
It just opens an upload window and says “Uploading” for ever.

When trying to upload an image with the File Manager it also says:
File Upload in Progress. Please try again in a few moments.

How to debug this? I have tested different things like saving the csv in different ways, trying to upload back the exported csv without changes etc and in each case the same issue. When I realised that issue comes also with the images, then I thought it may not be about the csv saving issue. Although first I was able to upload images but not import items. Then the problem came also for uploading images.

My Safari js console is saying this while trying to upload a simple test image to an item:
Failed to load resource: The operation couldn’t be completed. (WebKitBlobResource error 4.)