Item group empty on fresh install


I’ve been trying to install the latest version of ERPNext, with the easy install method of Bench on Ubuntu 18.04.3LTS. After figuring out the container issue, the locale issue, I end up having a function desk. Everything seems to work. However, when I try to add items, it seems that the Item Group tree is empty. There is no “All Group Items” master parent in there. I’ve tried to reinstall many times (thinking the pre-load of fixtures may have been jeopardize with the locale stuff), but nothing seems to do it. On the last run where I had no errors I did the following steps:

  • Create a system user and assign to the sudo group.
  • Install the python3-setuptools and the build-essentials package.
  • Generate and assign as default the en_US.utf8 locale to both LANG and LC_ALL in /etc/default/locale
  • Install Bench with the install script using python3 --container --user [user] --production --mysql-root-password [mysqlPasswd] --admin-password [adminPasswd] --site [siteName]
  • Run bench update

I end up having the following version: erpnext 12.1.0 and frappe 12.0.10 when checking with bench version. Up to that point, no issues at all.

After that, I open up my browser, login as Administrator, fill in the few questions on the company, etc. and first thing, I go check the Item Group Tree… and it’s empty! The new button doesn’t even work. I find a workaround to create a new Item Group (using the Item creation form, in the dropdown for the item group, you can click on create a new one). However, I’ve got the error Not Found - Item Group All Item Groups not found - The resource you are looking for is not available. I cannot even create that root group. All other default fixtures I can find seems to be there (unit of measure, project type, activity type, wharehouse, item attribute, chart of accounts, etc.).

The only thing I could find in the code is as if the item group fixtures are not processed, but the only thing I could find in the code is there erpnext/ at develop · frappe/erpnext · GitHub and they are alongside other fixtures that do exist!

On a previous attempt, I’ve tried to add All Item Groups item group manually in the database, however it did not go well; although the item tree was showing, creating a new item group was impossible as I would had an error in the line of “cannot create a item group under itself”, even though it wasn’t what the form was telling to do!

I’m kind of lost here. Any idea on how to resolve this?


1 Like

I have same problem too. if i can pass the setup wizard, Item Group Tree is empty, can’t insert any group / item.
tried drop site, re-add, remove erpnext and install it to site. Now, it stuck on setup_wizard, message on server says that it can’t find All Item Group.
checked the ‘tabItem Group’ table, and it’s empty. nothing there.

Am i missing some installation steps?
I’m new on this.

thank you

This is how the “All Item Groups” record looks like in the database for me, give it a try

INSERT INTO `tabItem Group` (`name`, `creation`, `modified`, `modified_by`, `owner`, `docstatus`, `parent`, `parentfield`, `parenttype`, `idx`, `image`, `lft`, `rgt`, `_comments`, `_liked_by`, `description`, `item_group_name`, `_assign`, `is_group`, `slideshow`, `show_in_website`, `_user_tags`, `weightage`, `route`, `parent_item_group`, `old_parent`) VALUES ('All Item Groups', '2019-08-29 15:39:02.542508', '2019-08-29 15:39:02.952698', 'Administrator', 'Administrator', 0, NULL, NULL, NULL, 0, NULL, 1, 12, NULL, NULL, NULL, 'All Item Groups', NULL, 1, NULL, 0, NULL, 0, 'all-item-groups', '', '');

this solve my problem. i tried to use bench to add All Item Groups, but it need All Item Group before insert the All Item Group :joy:


same problem here…

Thanks @mtaki14
This workaround works for me too :grin::+1:
I think this is should be reported as a bug.

ERPNext: v12.1.0 (version-12)
Frappe Framework: v12.0.10 (version-12)

Edit: Possibly bug reported

This worked for me.
For the non linux people, you have to be in the frappe-bench directory first. Then type:

bench mariadb

then copy and paste:

INSERT INTO tabItem Group (name, creation, modified, modified_by, owner, docstatus, parent, parentfield, parenttype, idx, image, lft, rgt, _comments, _liked_by, description, item_group_name, _assign, is_group, slideshow, show_in_website, _user_tags, weightage, route, parent_item_group, old_parent) VALUES (‘All Item Groups’, ‘2019-08-29 15:39:02.542508’, ‘2019-08-29 15:39:02.952698’, ‘Administrator’, ‘Administrator’, 0, NULL, NULL, NULL, 0, NULL, 1, 12, NULL, NULL, NULL, ‘All Item Groups’, NULL, 1, NULL, 0, NULL, 0, ‘all-item-groups’, ‘’, ‘’);

(from above) and hit enter. It will give an OK message. After that you can type \q and return to exit the mysql console.

Once I did this the all item group was there and I could add items.

After having issues with my whole server, I was finally able to launch this MySQL query. Everything works fine now. I guess a bug report should be opened in Github.

EDIT: Already created by someone else: V12 Missing "All Item Groups" · Issue #18950 · frappe/erpnext · GitHub


It worked for me too

Same issue for me. Manually inserting the SQL worked though. Something wrong probably with the installing fixtures?

1 Like

Wow, Thanks a lot.

This helps!!!