Kanban column transitions - Only on DRAFTs?

Hello, I’m running V13 and am using the Kanban Board view on several different DocType records, where the columns are based on Status.

Can records change status only when they are DRAFTS? Or can they be changed once they are Submitted? I am seeing the behavior of them ONLY being able to change on a DRAFT… and then NOT being able to change after Submitted.

However, I’d like to have the Status be changed after Submitted. Can this be done through configuration?

Further, I’d like to limit Status value by Role. Can this be done too?

Thanks in advance.

ERPNext: v13.17.0 (version-13)
Frappe Framework: v13.17.1 (version-13)

By default, a document’s fields cannot be changed after submit. That’s by design, as a submitted document is meant to be immutable.

It is possible to customize this behavior on a field-by-field basis. If you go into the customize form tool, you’ll see a list of fields. Pick the one you want to be changeable (here, the one mapped to your kanban state), open the details window, and mark “Allow on Submit”. That will allow the field to be changed after the document has been submitted.

(Note that this will only work on your own custom fields. Standard fields cannot be changed on production installations.)

1 Like

Peter, I think I marked the solution checkbox prematurely.

I modified the “Job Applicant” DocType and added my own custom field called “RichState” and made it “select” with values one, two, and three. and also marked Allow on Submit as you suggested.

I then created a Kanban board based on my custom field “RichState”… unfortunately, I am unable to change it’s state by dragging and dropping from one column to another. However, I am able to enter into the record, change the value, and then click save. After doing that, I return to the Kanban board and the record is in the updated column.

Am I missing something in the ability to drag & drop to change states?

Also after using the Customize Form tool and making the change to the custom field… when I click the “Update” button… I then see a popup at the bottom of the screen which says “Job Applicant Updated”. However, the status next to customize form continues to say “Not Saved”.

I’m new to the platform and have never submitted a bug. However it appears this is one.

Thanks, Rich

Because “Job Applicant” doctypes don’t have to explicitly Submitted… I modified the Delivery Trip doctype with a custom field, which I then built a kanban board based off of.

I got the same behavior as above… I could change the state of the custom field AFTER the record had been Submitted… but I could not do it by drag-and-drop (only by going into the record, modifying it, and then saving).

I am operating as an Administrator for all of these tests. Thanks.

Hmm…I’m not able to reproduce the issue on my system. Even on submitted documents, I’m able to change kanban columns so long as the kanban variable field is marked “Allow on Submit”.

One thing that may or may not be related: Job Applicant isn’t a submitted doctype on my system. Have you made it submittable with a workflow by any chance? I don’t see why that would create a problem, but it might be worth testing on other doctypes.

Yes, I tried it on Delivery Trip as well, which is explicitly Submitted and got the same behavior ( able to change the variable in the record but not able to drag and drop to change it). I may try a browser other than chrome and see if that has an impact.

Thanks for your reply

Interesting… the movement of records between columns:


  • Did NOT work on windows 10 with chrome (as described above)
  • Did work on windows 10 with Edge.
  • Did work on Linux Mint with Chromium
  • Did work on Windows 11 with Chrome and Edge

So… upgrading worked. Thank you again… appreciate you help!

1 Like

Hmm…that’s really odd. I just tested on W10 with Chrome, and it worked for me, but it might be a specific javascript version that’s causing problems. If you’re able to reproduce it consistently, it’d be interesting to know what the issue is. These kinds of JS issues are notoriously hard to debug, however.

Hi Peter. Unfortunately I have upgraded to W11 and don’t have a W10 box in which to test/reproduce.