LDAP not installed error when configuring LDAP integration, although it`s actually installed


I`m having the following issue: I am trying to configure LDAP integration, but it is throwing an error stating that “LDAP is Non Installed”. I did follow the LDAP install guide and the dependencies are installed, but the error still occurs. There is also an error with the text in the error message, as can be seen from the attached screenshot.

What can I do so that ERPNext will see that LDAP is actually installed?

Do you need any other information?

I am running ERPNext: v10.1.60 (master) / Frappe Framework: v10.1.53 (master) on Ubuntu 16, installed via the Easy Install method.

Try this one: - as frappe user

source env/bin/activate
pip install python-ldap

Hey Mohammad,

Thanks for the suggestion - I ran the 2 commands as the frappe user from inside the frappe-bench folder (running it from elsewhere it throws an error) and it appears they run correctly in that there are no errors. However, when trying to configure LDAP in ERPNext, the exact same error occurs and I cannot save the configuration.

Any other ideas?