Lead Import - Lead CRM-LEAD-2023-00001 already exists

ERPNext: v14.36.0
Frappe Framework: v14.46.0


I’m trying to import a simple list of leads. I’m getting an error for each of the 6 entries I’m trying to import (screenshot below).

I DO have a manually created Lead that has the ID CRM-LEAD-2023-00001. However, being an ID, I’m expecting the number to auto-increment when adding new leads, manually OR by import.

I’ve successfully imported when I added my own made-up ID numbers, but that’s not what I want to have to do. I’ve also deleted the manually-created lead and the import worked and IDs incremented. But what happens when I need to import more at a later time?

I’ve had import failures in the cases of

  • including an ID column in the csv, but no values
  • not including an ID column in the csv

Is there an issue here, or are my expectations wrong? How do I import records and not have to worry about the IDs, if possible?

Thanks in advance!

ERPNext: v14.36.0
Frappe Framework: v14.46.0

Hi @jdogcisco:

I’ve tried, importing without fill any data on ID column (but existing column), and its working fine …

Hi @avc ,

Can you clarify how you tested? Did you already have some Leads created? And then you are saying that your import and an ID column, but no data, and the import worked? The new leads auto-incremented?

If I include the column “Series” and specify “CRM-LEAD-.YYYY.-” the import will be successful when I already have other manually created Leads.

Is that a required import field? It sure seems like it.


It works for me without series column too.

Hi @avc ,

Ok. Thanks for the reply. Are you a developer or just an avid/super user? I’m wondering how to investigate this further. Any thoughts?


5% developer 95% FFF (Frappe Framework Freakie) :slight_smile:
Search for “Data Import Log” … in this doctype you will see all the import errors … maybe some clues there.

1 Like

Did you check the current value for the Naming Series in Settings? In the scenario you outlined, the current value for the Naming Series “CRM-LEAD-.YYYY.-” should be 1, meaning that was the last ID number created and the next one should use 2. If it is not set to 1 but instead set to 0, you would definitely get the “already exists” warning when creating a new lead by any means, manual or import.

1 Like

@avc , @trustedcomputer ,

I appreciate the help. I think the developer’s easy_install script is the issue. I’ve since wiped that out and installed manually as detailed in a post on here I just found…

So far, I’m not having this or the other weird issues I was running into.

1 Like