LetsEncrypt Renewal Failure

Not sure why my automatic renewal wasn’t triggered but today our site was throwing an error that the SSL certificate was expired. I jumped on and ran sudo bench renew-lets-encrypt and assumed this would work. Nope…

The attempt failed and I am scratching my head as to why. Are there any instructions on how to wipe Letsencrypt and start fresh? I spent a couple of hours trying to run down the various python arguement errors it reported. I would rather wipe it and reinstall fresh.

Hi @AV8

what was the error thrown by certbot?
what arguments have you executed exactly?
tried to setup ssl for your domain from scratch? - so I assume you have done this?:


Yes, I had a good working SSL certificate that failed to renew. I ran sudo bench renew-lets-encrypt and it produced the following error:

Processing /etc/letsencrypt/renewal/erp.av8tech.com-0001.conf

expected /etc/letsencrypt/renewal/erp.av8tech.com-0001/cert.pem to be a symlink. Renewal configuration file /etc/letsencrypt/renewal/erp.av8tech.com-0001.conf is broken. Skipping.

It also threw an additional error that I have made too many attempts in a given time. This is because I tried several times to correct it. The root isssue I believe is listed above which is why I wanted to remove and reinstall completely.


I take it that you are cloud hosted and it wanted to find symlinks - so has something changed on the server

That might help

Im not familliar with reinstalling certbot… actually dont know what happens as certbot needs certain files for the challenges to see if you are really the one owner since letś encrypt is a Cert authority after all.
So I would try to fix it rather then delete/uninstall and install again.
one has a history with the Cert authority! dont know what will happen if you start from scratch and there is no history on your server…