Letsencrypt wildcard on CentOS 8.2

I tried to install letsencrypt wildcard on a new server with CentOS 8.2 using bench setup wildcard-ssl and got this notice:

Skipping bootstrap because certbot-auto is deprecated on this system.
Your system is not supported by certbot-auto anymore.
Certbot cannot be installed.

I wonder if it is because of the CentOS version or is there anything new with the certbot on bench.

Can anyone please shed some light here?
Thank you very much.

I’m on Ubuntu 20.04, and got the same error today. Will look into it further when I get the chance and update.

Meanwhile, subscribing to this thread :slight_smile:

I don’t know anything about how bench manages ssl, but generally speaking it is correct that certbot-auto has been depreciated:

If bench requires certbot-auto, it will need to be updated to work in the future. In the meantime, you can always install certbot/certificates manually and add the locations to site_config.json manually.

you can use bench to generate the config and link to apache / nginx, manually edit the config and it is freely to execute on ssl config.

not sure certbot-auto but I have swap to snapd for control already

Hi there,

I had a similar issue and please try the below.