Letter head not visible on print formats other than standard

You can see HI HELLO TEST here, but if I change the print format. It disappears.

I can’t get letter head nor footer on print formats other than Standard. Is there a fix for this?

Have you set a letterhead in Settings , Printing?

In Settings, Print format are Print with Letterhead and Allow Print for Draft checked?

Are the print formats checked as Custom Format in the Print Settings for the format?

Yes, I have done it all. No luck.


Have you created a letter head in letter head list? If yes, please share a scrteensht of the same. Refer this link to know how to configure it: Letter Head

I have, please check.

Could you screenshot a print format that does not display the letterhead?

It’s in my first post. There are two SS.
Please check.

Share your print format code. The root cause maybe there.

Have you customized the Standard or Drop Shipping formats or are you finding that, out of the box , the Standard displays the letterhead and the Drop Shipping not? Or have you made custom print formats and the letter head does not appear on any of them?

Drop Shipping Format is a print format present in ERPNext by default. But not standard. It doesn’t appear for DSF as well.

So, its not about the code.

I have 3 print formats in total for Purchase Order.
Drop Shipping Format
Custom Format

The letterhead doesn’t appear for anything other than Standard.

1 Like

Can you check which letter head is getting fetched under “Print Settings” in the form once you select another Print Format?

Print Settings doesn’t have an option to select letterhead.

In your custom format is the Custom Format box checked?

If you have custom print format you may have to add these line in the HTML section at the start

{% if letter_head and not no_letterhead -%}
{% if print_settings.repeat_header_footer %}
   <br>  <div class="letter-head">{{ letter_head }}</div>
{%- endif %}{%- endif %}```

Yes, it’s checked.

Drop Shipping Format is not a custom PF. Doesn’t work for that either.

I have tried printing other doctypes too. Only ‘Standard’ comes with letterhead. Rest all doesn’t have a letter head.

Try unchecking Custom Format , saving and printing.

Tried. It doesn’t work for any print formats except ‘Standard’.

Does it work for you guys? Or is it just a problem on my machine?

I use the Customize feature from the print icon , unchecking the Custom Format box in edit Properties. Letter head prints ok.