Link field type unable to set default value

I using the feature of the setup → customize form → customer → then set the customer_group as default value Individual, but it still doesn’t set as Individual, still output as All Customer Group by default?

Is it bug ?

I am using v8.3.1.

try to edit in doctype
default set to any one option

for u write Individual

No luck, It is still the same, previous i was try on v8.0.1, everything work great than the version 8.3.1. , what i means is lesser bug, later version, is more bug.

Tried with command , bench clear-cache and restart the bench, but still not showing the default value of i set in doctype and customize form.

I think it is bug, Link type of link is unable to set the default value, i tried with the Territory in the customer doctype as well, the default also able to reflect, however for “Type” in the customer doctype which datatype is “Select” the default set is reflect well.

Is this a bug the link field type unable to set default value, even i set it, but it is not reflected.

Can someone please confirm to me is it a bug ? or how can solve this ?

Your help is much appreciated.


is this a bug ? customer group, unable to set default value, it always default to All Customer Group, instead of showing default value like ‘Individual’, i already set it in customize form or doctype, will this a bug for recent version ?

I have the same issue, with latest master (v9)

I am also facing the same issue in the latest version 10. I would really like to have this option to set default for Linked Field.

Still having this issue in version 12…

yes same issue here v12