Link type field in new doc does not show up while creating new entry

I am trying to follow the Library Management tutorial - Library Management
I have created the Library Member class and they have a few entries in them. I have created the Library Membership DocType as instructed. But the linking way seems different in the newer updated version. I am able to select the Library Member class and the full_name field for the full_name field in Membership class as shown below.

However when I try to create a class, I cant see the Library member field to enter the member.

@ankush can you please help on this if you have any leads?? We really want to use this for building our webapp

Hard to guess what exactly is going on here but try this in browser console.


It will tell you all the information about why a field might be hidden.

Hi Ankush… thank you so much for your reply… I tried out what you had asked me to. And I have attached the screenshot of the output below. I think the By Read Only and By Set Only Once have different permissions from your output. Not sure what they imply though.

Just an update. I downgraded my frappe-bench installation to v5.14.0 - It works now.