LMS issue: error when opening program

Dear All,
I faced with this error when click on LMS program:

Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 49, in render
data = render_page_by_language(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 178, in render_page_by_language
return render_page(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 194, in render_page
return build(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 201, in build
return build_page(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 224, in build_page
html = frappe.get_template(context.template).render(context)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/jinja2/environment.py”, line 1090, in render
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/jinja2/environment.py”, line 832, in handle_exception
File "/home/frappe/frappe-bench/env/lib/python3.6/site-packages/jinja2/compat.py", line 28, in reraise
raise value.with_traceback(tb)
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/./www/lms/program.html”, line 62, in top-level template code
File “/home/frappe/frappe-bench/apps/frappe/frappe/./templates/base.html”, line 83, in top-level template code
{% block content %}
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/./www/lms/program.html”, line 77, in block “content”
{{ card(course) }}
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/jinja2/sandbox.py”, line 462, in call
return __context.call(__obj, *args, **kwargs)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/jinja2/runtime.py”, line 679, in _invoke
rv = self._func(*arguments)
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/./www/lms/program.html”, line 55, in template
{% if has_access and progress[course.name] %}
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/jinja2/sandbox.py”, line 384, in getitem
return obj[argument]
jinja2.exceptions.UndefinedError: ‘progress’ is undefined

1 Like

Any solution to your error?
I have had a similar error.

i have the same problem after update the version .

Any solution to this?
This was working before…

which version of erpnext you were using previously?


This hotfix didn’t resolve the problem

I am also facing a same issue

did you get any resolution on this ?

I have tried many ways and found at least you must have one student enrolled the program. But the LMS still not work as expected, I cannot see the progress although I have completed the course.

If you are on Main Branch of LMS so It will not work. you have to switch your branch from main to version13 then it will work.

also if erpnext is already installed before lms so courses webpage will not work as there is a template in ERPNext too with the same name.

you can use web page with Course web template to publish your courses.


1 Like

Now I can install lms together with my erpnext but when I create a lession system throw error during saving:

May you guide me how to make course web template as you mentioned.
Thanks a lot

The error is still present in ERPNext version 13.

Jinja is complaining “progress” is undefined.

Is something messed up among render.py, program.py and program.html?

Administrator, System Manager and Unenrolled student can view programs, but not instructors, etc. No idea why permission matters in this case.