Localhost:8080 looses ":8080" and does not open next page

I was on admission list page of the website. (ERPNext Education module)


when we click on any program listed for admission

Then the page that opens is

the link address does not have ‘localhost:8080’. It only has ‘localhost’

it works when :8080 is manually added to the address

I don’t know how to go in its source code and fix it myself.
If anyone is willing to help. It will be much appreciated, or if any team member gets it fixed in next update that would be wonderful. Thanks in advance :smile:

or you can make your VM Network Settings NAT to Bridge and if you want to restart your VM you can write command sudo reboot.

If you restart the VM you have to enter login details.
After that type ifconfig you will find the inet ip your network ip.
for example:
type this ip in your browser like

Hope it will resolve your issue :slight_smile:

Thanks for solving the issue @rak

Though the problem persisted while using It again removed :8080 and it didn’t work.

But converting NAT to Bridge and by using VMs IP, not only did it work. I also prefer this method. It just sits well with me. Thanks again. :smile:

Great :slight_smile: . Good to hear your issues is resolved