Login Page - Default to Desk

We use a hosted version of erpnext. After the V7 update, our login page on the website does not work correctly. I have set the home page to “login” and the login page shows as the homepage. The issue is that when I enter my username and password, it just sits there. When I click Login in the upper right hand corner, then it logs me into the site, but to a weird page. Then I have to select “Switch to Desk”. I want to just be able to enter my login info in the center of the webpage and have it automatically take me to the desk. Is this possible?

I’m not using the website functionality, so i set my Home Page in Website Settings to “desk”

1 Like

Thank you for the response. I tried that, and it takes me to a “Not Permitted” page with a login button. Once you hit the login button, it then takes you to the login page. I am trying to bypass this. You used to just be able to go to the login page, and it would take you to the desk. Now it does not work…

@vpops if you have any role, the login page will take you to the desk after login. What is the change of behaviour you are seeing?

Its now working, did you change anything on your end?..

This is weird. Now we are having issues with the item table in quotations. If you edit, add, or move an item, it completely deletes everything in the table. Struggling with the update so far…

I had the same issue.login issue i solved by clearing the browser data and second issue still exist.system automatically deletes data from table fields on event.issue exist from frappe version v7.0.19

Great job.
I have a user who is also a customer and a blogger.
I don’t think they need access to the desk at all.
Would be nice if their login takes them to the website
directly after verifying and changing their password on
first login.

The roles selected do not need any desk access.

Still looking around for that option.


I have the same issue please how did you solve this?