Mail setup with Google Groups aliases

I have groups setup on my Google Apps for Work account, so that group emails are accessible to different accounts, like or

Basically all addresses ERPNext would use are actually aliases and are managed by an account whose credentials do not match the address. In my setup, I have that the group who responds to, and other aliases. When somebody hits on of those aliases, receives and email.

How can setup such addresses on ERPNext? For what I see in setup, the actual address and the login must be the same.

If you go to the email account page, there is an option for login id is different.

Thanks a lot @cpurbaugh, actually I’m missing this option. I looked everywhere in ERPNext > Setup > Email Account > Account.

All items in Email Account List have a Service, Email Id and Password settings. Then I have options for Incoming and Outgoing servers, but not such a thing to separate the address from login. Can you please point me in the right direction?

I tried investigating some more thanks to your hint @cpurbaugh :slight_smile:
I found that there is an email_account data field next to password in the same form section. Is that the one you are referring to? Unfortunately, it is not exposed in the UI… I also tried logging in as Administrator to see whether it was a permission issue, but it’s not.
Still I can’t find a way to define discrete login and email address…

There should be a check field, login_id_is_different

Try going to customize form and making sure it’s not hidden.

@cpurbaugh, many thanks to ping me back!
I attach you a screenshot of the section, and after inspection, I can see no related check fields.
Here are all check fields in that form:

  1. enable_incoming
  2. use_ssl
  3. default_incoming
  4. notify_if_unreplied
  5. enable_outgoing
  6. use_tls
  7. default_outgoing
  8. add_signature
  9. enable_auto_reply

They are in order and none of them in the same section block as email_id. This is a fresh install pulled from docker docker pull davidgu/erpnext. Please do let me know if you see what’s missing :slight_smile:

Sorry, I’ve got nothing. Perhaps open a github issue?

All right, thank you for your effort @cpurbaugh! I just opened an issue. Will keep you posted :slight_smile:

Kindly note that the Docker image consists an older version.
It is nonofficial and released by one of our community member.
For updates, you should contact docker image publisher.

Otherwise install ERPNext latest version using bench tool: GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps

The latest version which my test server running in production mode installed using latest bench yesterday. Does have the option to enable Login Id is Different

@yashodhan is totally right and the latest version works correctly, thank you!
However don’t understand how davidgu/erpnext docker image is old. It does fetch the exact latest script as the github repo.

Anybody has fix for this? The docker image is just so convenient and it deploys super fast!

Can you do bench update in your docker?

Buddy, there’s no way to make it work. You might want to try it as well. Installation is so straightforward. Basically I get stuck on node update and then pillow update… I can get past node by installing curl and then node, but pillow will get stuck on some dependencies.

It sucks, because that dockerfile is damn good otherwise!
Still I’m a bit puzzeld because actually the running bash script is exactly the same as the latest version. So how is that you get erpnext v5?

Dockerfile source: it does not follow standard way of installing ERPNext using Bench tool and hence needs updating manually.

FROM debian:wheezy


RUN useradd $FRAPPE_USER && mkdir /home/$FRAPPE_USER && chown -R $FRAPPE_USER.$FRAPPE_USER /home/$FRAPPE_USER


RUN  bash /
RUN apt-get -y remove build-essential python-dev python-software-properties libmariadbclient-dev libxslt1-dev libcrypto++-dev \
libssl-dev  && apt-get -y autoremove && apt-get clean && rm -rf /var/lib/apt/lists/* /tmp/* /var/tmp/ /home/$FRAPPE_USER/.cache

VOLUME ["/var/lib/mysql", "/home/frappe/frappe-bench/sites/site1.local/"]
COPY all.conf /etc/supervisor/conf.d/

CMD ["/usr/bin/supervisord","-n"]

Oh no, it does… Please check the github repo and please pay attention to line COPY
You may want to build your own image locally from that…
It runs exactly as the recommended way:

apt-get update && apt-get install -y wget ca-certificates sudo cron supervisor

bash --setup-production
rm /home/frappe/*.deb

exit 0

Though I have not tried it after quite some time.
But Pay attention to Users reports as well: update to ERPNext 6 · Issue #7 · pfy/erpnext · GitHub

Nope, doesn’t work… think it has something to do with node not being installed or something…