Maximum File Size


What is the maximum limit of a single file size which can be uploaded as an attachment in ERPNext
for hosted users and for local users?
Also, what is the way to increase the size limit of a single file?
Is there any capping for number of files to be attached?


File size limit of 1MB is applied on hosted as well as local accounts.

From the the local, you can remove this restriction from site config. You
can expect to hear more on this on our technical experts.

For hosted account, limit on the file size cannot be increased.

For no. of files which can be attached against a document, you can
configure it for a specific document from Customize Form.

Hi!, i understand that the following file must be edited in order to increase the file size limit?


But i do not see here any restriction, only db_name and db_password


add max_file_size": 1000000 in your site_config.json

For other option please see:


Is it in Bytes, KB or MB?

File size is in Bytes.


@kolate_sambhaji in case you don’t have such an entry (which is the default) file size is unlimited?

@vrms If file size is not mentioned then it will be 10MB by default.
You can try to attach files with big size, you can also create free account here and test ERPNext.

1 Like

This is you are asking about testing on frappe account.

I just want to know is there any capping for maximum file size?

Ruchin Sharma

@ruchin78 By default there is 10MB limit, you can increase max file size limit depending on your server configuration.

I doubt it works for heavy files.
I tried increasing file size and then I attached a 33 MB file.
First thin was happened that system stucked and secondly it showed me a dialog box to debug the script.

Actually, I wanted to use this system for document management therefore before using it in full swing I wanted to do a stretch testing for the same.

I appreciate if anyone can help me in this regard or anyone can let me know what is the maximum limit of file size.

Note: I am using on my local instance installed under vertual machine and I have no issue with the space.

Edit: @umair @vrms

Ruchin Sharma

@ruchin78 clear-cache and try to upload again.
It should work.

I did it and tried so many times but it didn’t work.

Ruchin Sharma

1 Like