Message: Field not permitted in query: occupancy_status .. When working in the workspace

I created a custom workspace, and now I’m facing a problem when I want to work on this workspace, where I get this message: “Field not permitted in query: occupancy_status”!!!
What does this message mean?? And what’s the problem??
I need help… :woozy_face:

2 Likes

Does anyone have a solution to this particular error ?

Late edit: this error generally appears when there’s an error in the naming of the custom field. In my case, I was not mapping the fields with the correct names for fetch from.

@MohamedAbdulsalam I have the same problem, and I can’t figure out why?
Please, if you come up with some solutions, share it with me…

there are 2 cases you can check

  1. look at field permission level , this you can set in role management

  2. maybe you are using the wrong field name, please check .

@usersive I already found the reason for this message, and I fixed it before. I don’t remember exactly what it was??..but I remember the error was coming from the workspace document… I’ll tell you exactly what to do, later.

2 Likes

I’m waiting for you my friend

@ziad_alswary Can you contribute here?

2 Likes

I got this error when I open a certain workspace, so if this error appears with you when you open a workspace
All you have to do is go to BuildWorkspace → chose the workspace that has this error
then in the Shortcuts section open and check every Shortcut’s Count Filter conditions
Make sure that all fields you wrote in Count Filter field are exist in the Doctype that selected in Link to field

2 Likes

Yup…
This solved my case.
Thank you very much my bro.

1 Like

You r welcome bro :v: