Message: Invalid Method on all pages

after upgrade to v13, getting Message: Invalid Method on every page. not sure where it is invalid; where do I look for this?

When homepage loads, message box : Invalid Method pops up. Click on “Login” to go to Login page, and message pops up again. I can enter user name and password, login bar says “success”, then get same error, then “/app” page tries to load with ERPNext logo in middle of page and won’t go anywhere else.

Hope this may help!!!

Bench build --force
1 Like

Hi Suresh
I have the same problem , I run this command but still having this error : command failed with exit code 1

@Brahim_Chabane welcome to the great community,
Please share full traceback so any one can help.

I also ran into this issue, here is the issue:

root@igterptest:/home/frappe/frappe-bench# bench build --force
yarn run v1.22.4
$ FRAPPE_ENV=production node rollup/build.js
Production mode
:heavy_check_mark: Built js/moment-bundle.min.js
return, stringToFlags(flags), mode);

Error: ENOENT: no such file or directory, open ‘/home/frappe/frappe-bench/apps/frappe/node_modules/localforage/dist/localforage.min.js’
at Object.fs.openSync (fs.js:646:18)
at Object.fs.readFileSync (fs.js:551:33)
at (/home/frappe/frappe-bench/apps/frappe/rollup/build.js:129:39)
at ()
at files_to_concat.forEach.output_file (/home/frappe/frappe-bench/apps/frappe/rollup/build.js:123:36)
at Array.forEach ()
at concatenate_files (/home/frappe/frappe-bench/apps/frappe/rollup/build.js:120:18)
at Object. (/home/frappe/frappe-bench/apps/frappe/rollup/build.js:40:13)
at Module._compile (module.js:653:30)
at Object.Module._extensions…js (module.js:664:10)
at Module.load (module.js:566:32)
at tryModuleLoad (module.js:506:12)
at Function.Module._load (module.js:498:3)
at Function.Module.runMain (module.js:694:10)
at startup (bootstrap_node.js:204:16)
at bootstrap_node.js:625:3
error Command failed with exit code 1.
info Visit yarn run | Yarn for documentation about this command.

I get this “Invalid Method” message on the frappe cloud instance. Any pointers to solve this ?

Then apply

Bench build --force

Hi @Suresh_Thakor, thanks for your comments, followed it and seems working after “bench update”, no more message “Invalid Method”.