Message: Password not found

when i am submit my form i got this type of error…
how can i fix it???

Thank you in advance…

have you no any solution of It???


maybe some more information can help to give some clues… can you share details on your form code? What method are you posting to? From the screenshot it looks like this form works when the user is not logged in correct?

Have you created web-form for this? If yes, please share it’s screenshot.

In the web-form, is field Login Required checked?

login required checked.

module “desk” must checked login required.

still Not Work…

have you another way to solve it??

Hi @Yashasvi_Chhapariya,

I have tried to reproduce your issue, created an “Application 6000” DocType in a custom application and recreated the form. I have kept the module in “custom app” (tried Desk, worked too). Both with login required and without login required worked and created the new records.

Have you tried to fill in the form in a new private browser window (to prevent any browser form filling)?

Is there any additional message in the browser console view (F12)? (The error would indicate a call to frappe/frappe/utils/…)

Which version of Frappe/ERPNext are you using?

The form:

After clicking save:

And in the record view

Getting the same error message.

  • I have an app that was created under Frappe v11.
  • It’s Settings DocType has two “Type: Password” fields to store some API keys.
  • The keys are only used by code, via self.get_password("api_key").

This works perfectly well on v11. Now I installed this app on a Frappe v9 server.

  • When I save the “Settings” document, I get two “Password not found” errors (one for each field).
  • If I fill the password fields before saving, I get the errors and, additionally, get logged out.

Just so you know :grin: