Missing CSS on Production System (path problem in nginx?)

I have set up (against all recommendations, I know :blush::sunglasses:) an Arch Linux station for which I want to use for a production system. The setup was a bit challenging but with all the available info on the forum, that part is mostly working.

The current minor problem is the appearance of the pages, and missing js functionality. I am not 100% sure which part(s)/port(s) to change. Port 8115 is to allow port forwarding on LAN/WAN for external access. Left side is how it looks and Right side is obviously how it should look, and the JS elements are not loading, which means it also doesn’t work. (Again, I understand that I should probably not have messed with this, but the system works so well in Dev/VM mode that I had to try it out in production)

Error message in nginx.log indicates that ownership/location is mismatched

GET /assets/erpnext/css/website.css HTTP/1.1" 404 169 “http://archerpnext:8115/

some config info is below:
from nginx.conf (relevant piece - all the rest is standard)

server {
listen 8115;
server_name site1.local archERPNext:8115;
root /home/frappe/frappe-bench/sites;

All files in the /home/frappe/… are owned by frappe.frappe

from frappe-bench.conf/ini and supervisor.conf

command=/home/frappe/frappe-bench/env/bin/gunicorn -b -w 2 -t 120 frappe.app:application --preload

upstream frappe-bench-frappe { server fail_timeout=0;}
upstream frappe-bench-socketio-server { server fail_timeout=0;}

and processes running (trimmed a little to make them smaller)

frappe 2520 /usr/bin/redis-server
frappe 2521 /usr/bin/redis-server
frappe 2522 /usr/bin/redis-server
frappe 3088 /home/frappe/frappe-bench/env/bin/python -m e schedule
frappe 3089 /home/frappe/frappe-bench/env/bin/python -m e worker --queue default
frappe 3090 /home/frappe/frappe-bench/env/bin/python -m e worker --queue long
frappe 3091 /home/frappe/frappe-bench/env/bin/python -m e worker --queue short
frappe 3101 /home/frappe/frappe-bench/env/bin/python2 /h /gunicorn -b -w 2 -t 120 frappe.app: n --preload
frappe 3102 /usr/bin/node /home/frappe/frappe-bench/apps
frappe 3149 /home/frappe/frappe-bench/env/bin/python2 /h /gunicorn -b -w 2 -t 120 frappe.app: n --preload
frappe 3150 /home/frappe/frappe-bench/env/bin/python2 /h /gunicorn -b -w 2 -t 120 frappe.app: n --preload
root 3588 nginx: master process /usr/bin/nginx -g pid /run/nginx.pid; error_log stderr;
http 3589 nginx: worker process


@trentmu i have the same problem, did u fix it?

I was not able to solve it on that ArchLinux installation, but I installed on a Debian Stretch 9.4 station with no problems at all. I wanted to get it working on ArchLinux as that is my preferred Desktop WorkStation - however, I do not have enough experience/knowledge to get that working (yet).
I followed the debian manual installation guide, and the install was very smooth/easy.
I did a few minor tweaks on the document to work with my personal preferences, (I am happy to send you those if you want), but the default recommendations work perfectly well.

@codingCoffee might help you. He also uses Arch.

@trentmu first of all, it’s great to see another fellow Arch user :smiley: . Arch is my preferred distribution as well and yet I would highly recommend AGAINST USING it in a production system.

Now coming to your question, I did not have to make any changes to any conf files to get the system working. Here is the link to the Arch wiki for ERPNext: Install ERPNext on ArchLinux · frappe/bench Wiki · GitHub I never faced any such problems.

@Hala_Atef @trentmu you can give it another shot if you like by following the Wiki

Thank you @codingCoffee - I will definitely check that against what I did and see where i went wrong. I will update when I succeed.
On a related but separate note…I don’t suppose you have/know of a FreeBSD install? I have a FreeNAS machine that I would like to expand. I could do a VM/jail/iocage there, but would prefer to run it raw if possible. (I will experiment on taht when I have some time, but if you have a working one, that would save me a lot of time).

Thanks for an awesome system!

@trentmu, nope I’ve not entered the BSD realm yet, won’t be able to help you out there : )