Missing page - How to create a page with No Route

When I go to my site URL and have NO route appended to the URL, I get two different behaviors:

  1. if I’m logged out… it redirects to the Login page, which is fine. It seems Home redirects to Login if not logged in. This is desirable.

  2. If I’m logged in (as Administrator), I get the message “Page missing or moved”.

Things tried to eliminate this:

I created a “homepage” per the instructions. I would assume that this page would be loaded when there is NO route in the url - however this does not seem to be the case.

I created a published webpage with the route set to “shine”, and then went to Website Settings and set the Home Page value to “shine”. I still get the error below when I hit the URL with no route.

Question: How do you create the page with No Route??

Also, when I’m on the company webpage (not desk) and click on “Home”… the page reloads with the route /index. I would think it would load /home instead.

When I goto the Homepage docType there is not a place to set the route - so, I presume it should be the page loaded with No Route. Btw, Homepage says that it is “under development” on the top left. Any way to unset that?

Thanks in advance. I really have tried to read all the documentation before asking for help on this matter. Thank you.

are you talking about a “page not found” page ?
this one ?

No… talking about “Page Missing or Moved”… see my screen shot.

In “Website Settings”, what value do you have under “Home Page”? Whatever page is listed here should be the one routed to the root. Try putting “home” here if you want the default home page.

Hi, In “Website Settings” I have “shine” under the Home Page value. A also have a web page with “shine” as the route. However after saving both, and then refeshing the page of the root URL… it still shows the “Page Missing or Moved” error.

Additionally, if I change the Home Page value in the Wetbsite Settings to "home, then loading the base url (without any route) does NOT redirect to /home. I believe it should do this per the documentation. As a side note, if I load /home … then the home page does successfully display.


Thanks for the extra info. It sounds like a caching error of some sort, or perhaps an interfering customization. I don’t have much advice, unfortunately. I just tested on my dev site (v13.16) and it’s working fine.

1 Like

Thank you!!!