Module 'lib' has no attribute 'X509_V_FLAG_CB_ISSUER_CHECK'

I’m getting the following message when doing bench update, how to git rid of it
Using version 14.6

frappe.integrations.doctype.s3_backup_settings.s3_backup_settings.take_backups_daily is not a valid method: module ‘lib’ has no attribute ‘X509_V_FLAG_CB_ISSUER_CHECK’
frappe.integrations.doctype.s3_backup_settings.s3_backup_settings.take_backups_weekly is not a valid method: module ‘lib’ has no attribute ‘X509_V_FLAG_CB_ISSUER_CHECK’
frappe.integrations.doctype.s3_backup_settings.s3_backup_settings.take_backups_monthly is not a valid method: module ‘lib’ has no attribute ‘X509_V_FLAG_CB_ISSUER_CHECK’

from your bench folder, type the command:
env/bin/pip3 install pyOpenSSL --upgrade.
I hope that helps


Thank you @chrismberi , your solution is perfect


Thank you very much your solution is amazing :wink:

1 Like

Ive tried the same approach but all my pip3 commands are returning the same error:

AttributeError: module ‘lib’ has no attribute ‘X509_V_FLAG_CB_ISSUER_CHECK’

I tried pip3 uninstall… pip3 -V … etc all with the same error

Thank you @chrismberi for this.

I get the same error on V13.39.1

I assume I have to run
bench update
again … after aplying your suggestion ?

So I dont know whether its a solution or a workaround, but i managed to avoid it by installing Frappe and erpnext v14 on ubuntu 22. the dependency above is the result of some deprecated libraries and the cause this issue.

1 Like

Yep, this did the trick!

env/bin/pip3 install pyOpenSSL --upgrade