Multitenancy in virtual box ova

I am using your virtualbox ova, but am unable to get multitenancy, despite carrying out the commands in the vb shell. FOr example, if i set the port as 81 for a new site, I dont get it when typing localhost:8081 on my host browser. please help

What have you tried? Can you reproduce your steps

I am using your virtualbox appliance (OVA) on my host Ubuntu Trusty.
I set up the 1st site and was able to use it from the host browser at address localhost:8080
Thereafter, I created a new site using the following:

bench new-site site2.local
bench set-nginx-port site2.local 82
bench setup nginx
sudo service nginx reload

I could not access localhost:8082 (also logged out from the VM and tried again)
Thereafter, I edited the settings of the VM Port forwarding and added 8082 on host as well as guest on the table. Yet, was not able to use the new site. The browser (both chrome as well as firefox) shows “This Webpage is not available” and “ERR_CONNECTION_RESET”.
Please guide.
Thanks in advance.

I am getting same problem. I am using Oracle virtual Machine. i set up first site and was able to use it at Localhost:8080.
Then I created new site and setup port 9000, but i couldn’t access it at localhost:9000.(I tried this for 4-5 times).
I run following commands:-
bench new-site site2name
bench set-nginx-port site2name 9000
bench setup nginx
sudo servise nginx reload
bench restart

I tried to set port 82 also but still getting the same error.
The browser show
"This webpage is not available


Please guide.

You have to setup port forwarding in virtualbox,

I have already tried adding ports 8082 in the tables of port forwarding for the VM, but it’s not working. Please refer my earlier post. In case it is a firewall issue, please guide how to allow it in your VM.


i’m getting same error. How can you solved this issue.

It is not working in VB. I installed Ubuntu in another partition and using erpnext with multitenants on the same.