Multitenant & Let's Encrypt browser stays at connecting

I am trying to become more familiar with the production set up and trying to get DNS based Multitenant & Let’s encrypt working.

I followed the directions at: Multitenant Setup · frappe/bench Wiki · GitHub and successfully set up two sites. Tested each domain and they point to thier respective erpnext install.

However, when I follow the directions at:'s-Encrypt-for-ERPNext-sites . (Im not using the manual mode, using the bench mode)

No errors are dislayed during the commands, but when I try to access the site I just used in the lets encrypt setup, the browser just hangs at “connecting…”. I have tried to restart nginx, and even a reboot… Same results.

I can still access the other sites hosted via DNS Multitenant, just not the site set up with lets encrypt. I tried access it va ‘http://’ and ‘https://’ and still just hangs at “connecting…” I checked to make sure port 80 and port 443 are open on my firewall.

Any suggestions?

my site folder name under the sites folder is the FQDN . –

in my site_config.json I haven’t added a host yet.

From what I understand this isn’t neccessary if the site name is the FQDN. However, I was going to add it anyways.

On these forums I am seeing the follow format for the host entry.

 "db_name": "xxxxxxxxxxxxxx",
 "db_password": "xxxxxxxxxxxxxxx",
 "host": "

Is the “http://” required or can I use just, or should I use “https://”

after a fresh install, and naming the site the FQDN and leaving out the host in site_config.json. It seems to be working as expected now. Not sure what the issue was earlier.

1 Like