My web browser caches the website

Hello All,

I am having a strange behavior here.
When I make changes my website does not reflect the change.
I know the change happened because if I go to a new browser where I have never visited the site, I see the new changes. However, the new browser just caches the information and newer changes also will not reflect. So something is making each browser cache the state it meets the website in.

using the bench cache commands obviously won’t resolve this as erpnext seems to have updated with the new site. It is the browsers that seem to be doing this. I believe it is connected to ERPNext but not sure how. It was working fine about 12 hours ago as changes reflected automatically. It just started this morning.

Clearing the browser cache also does not work.
Any help will be appreciated.


@tiwiex I got same problem in one angular website.

However its not our angular app or browser issue, its due to cloud flare which is our DNS and hosting provider. Once we cleanup cache from cloud flare, then new changes reflects immediately, else we need to wait for some time.


1 Like

I don’t think this is the issue here but I just might be wrong.
The caching happens at the browser level for some strange reason.
And it happens to the Erpnext website only.


Eventually resolved. I wasn’t in development mode. I had to enable development in the site_config.json file. Added the “developer_mode”: 1 to the objects.

Just thought to post my solution incase someone needs it.


1 Like

For anyone whole lands here facing issue with delayed page updates.

  1. frappe caches www pages
  2. if you are displaying dynamic content cache should be cleared.
  3. use context.no_cache = 1.
1 Like