Need help in subcontracting item in V7

Dear Team

One of our client need the subcontracting feature in erpnext version 7

however as in the item description i found out that the checklist for subcontracting item are
not selectable anymore.

however if i followed the proper procedure for subcontracting item, i still have to define the item as subcontracted.

Question is how to define that the item is subcontract item



In v7, you must have “maintain stock” selected in the item form for each item. Then if you scroll down the form you’ll see the “manufacturing” section. Check the “supply raw materials for purchase” box. This marks it as subcontracted.

I am sorry i know,

i used to have that. is this only my server or other also,

eventhough i ticked on the maintain stock checklist, the manufacturing section break did not show itself.
I checked on the doctype and the collapsible depend on, compare it with inventory section break, all seemed okay, i tried to duplicate the section break setting with the inventory section break settings and reload the form, the manufacturing section did not come out still up to now.

This is my screenshot, if you are experiencing the same issue please give me feedback…

I think i found why

In the Item in Doctype,

The section break module by default are not hidden and are depend on is_stock_item checkbox. it seemed okay.

However on the customize form section, the Manufacturing section break is Hidden checkbox are ticked.

I untick the hidden in the customize form section and are now showing without problems.

I checked with a new clean development server that i installed just now, the custom form in the manufacturing section break are also hidden by default setting.

Do you think i am only the one who experience this or is this a glitch?

attached are my screenshot of item in Doctype and Item in customize form

Item in Doctype – seemed okay

Item in Customize form, I dont know but in my server the hidden is ticked. I tried with new instance on new site in my dev server. the default that i see is also ticked - hidden.

Thanks to @Dbone

I found the problem

Thank you