Need help on installation using production mode


Im using ubuntu server 18. this is locally hosted

So this is the step i did

  1. wget
  2. python --production (frappe-bench folder isnt located at /home/frappe/frappe-bench. its in the root)
  3. bench setup supervisor
  4. bench setup nginx

I tried accessing erpnext on 192.XXX.X.XXX:8000 but couldnt connect return error connection. does nginx and supervisor start immedately?

I checked the services with “service --status-all”. nginx has a minus sign while supervisor has a plus sign.
I tried starting nginx and it gave me this error
“Job for nginx.service failed because the control process exited with error code.
See “systemctl status nginx.service” and “journalctl -xe” for details.”

how do i start production mode? did i make a mistake?


Have you installed all the other requirements as well? MariaDB, Redis, Node, Yarn etc?

You’ll find the pre-requisites here

i used the easy install to im assuming it will install all prereq

this is the easy install script right?

What error are you getting after you do bench start?


this is a production not developer so i dont think i can use that command

it works when i use bench start. im able to access erpnext on my browser. does this mean that i am on developer mode and not production mode?


Do a bench version and it will show what you are on


when i went to the erpnext app it shows v12. damn was there something it did wrong?

ERPNext: v12.x.x-develop () (develop)

Frappe Framework: v12.x.x-develop () (develop)

If the installation is in the root, then something went wrong. It should be installed as a non-root user (eg. frappe)… to that user’s $HOME (eg. /home/frappe) where it should create a “frappe-bench” subdir. The user should be able to run sudo commands.

  • If you install production, it should start without bench start.
  • If you already had an installed/running nginx/apache, then the script is likely to fail because it cannot assign the port and therefore doesn’t finish the nginx install properly.
  • If it’s showing v12, then it installed a development version instead of production, so it needs a “bench start”

I recommend that you reinstall using a manual method so that you can see the errors more clearly

1 Like


how do i uninstall or remove my copy so i start fresh without any hindrance?

do i need to create a frappe user? or should i name that new user different

That would be best


how do you do a clean uninstall


You don’t need to do a clean install as you can switch to master which is v11

bench switch-to-master

will that solve my issue with nginx?

still experienced the issue with nginx. this is the error message according to systemctl status nginx.service

atomic_server systemd[1]: Starting A high performance web server and a reverse proxy server…
atomic_server nginx[19918]: nginx: [emerg] open() “/etc/nginx/conf.d/frappe-bench.conf” failed (2: No such file or directory) in /etc/nginx/nginx.conf:75
atomic_server nginx[19918]: nginx: configuration file /etc/nginx/nginx.conf test failed
atomic_server systemd[1]: nginx.service: Control process exited, code=exited status=1
atomic_server systemd[1]: nginx.service: Failed with result ‘exit-code’.
atomic_server systemd[1]: Failed to start A high performance web server and a reverse proxy server.


Not sure really, without more info as to your setup.

With regards to Nginx config, its usually managed by bench and to set that up you would use

bench setup nginx

As @trentmu mentioned it may be better to do a clean install and doing a clean install.

Are you running on cloud server or metal local?



Provided you have the following already done:

  1. created a user frappe as sudden
  2. have all the prerequisites
    Then do the following:
  3. you can delete the exiting frappe-bench directory
  4. delete the db that was created (if any)
  5. do bench init as follows → bench init frappe-bench --frappe-branch master

Once you have everyting running meaning the install completed and you can access the setup screen

Then do bench setup nginx for bench to nginx to run properly.

Hope this helps

both nginx and supervisor are now running ok after i deleted the existing nginx.

all i need to do is access erpnext on the web browser right? how do i access erpnext on the webbrowser?
i tried 192.XXX.X.XXX:8000 and its not working


Yep and if you are running ERPNext on another machine (being your local server), basically, the IP address of that server should be all that you need.

Double check your local server IP is all I can think of and can you ssh to it from another computer and where are you actually accessing ERPNext from, another computer?

hmm i have nextcloud(snap ver) running so when i accesss the server’s ip it directs me to the nextcloud instance or do i need a specific port?


I have no idea what the setup of Nextcloud is like, but by default ERPNext defaults to port 8000 and you would access it using the host IP unless you setup DNS & so forth.

If Nextcloud is using port 8000 yes you would need to assign a different port and you can use

bench set-nginx-port
bench setup reload-nginx

Ideally you keep the same port 8000.