New Hyper-V install from OVA

I just converted and installed the newest version of the ERPNext from the OVA container to Hyper-V.

The conversion seemed to go without issue. However, when running the VM I’m able to log in but cannot ping any IP other than localhost. Note: the VM Switch is active and connected to the VM. I continually get the error message connect: Network is unreachable.

Could someone please point me to where the the network configuration can be modified to include the local network Config?

Note, I’ve tried
1. editing /etc/network/interfaces to add the requisite eth0 information but I’m guessing it’s not used here.
2. Editing /etc/host to include a static IP to the server. But, did not work.

Any direction would be appreciated.

I’ve tried 3 different conversion methods, i.e., StarWinds V2V, MS Virtual Machine Converter and finally the native Oracle VirtualBox Copy to VHD.

In each case I’m able to load and log into the VM but the networking is not available. In the last case, using the Copy to VHD on Oracle VBox I had successfully run the VM under VBox and installed all updates and net-tools.

Is there anyone that can point me to an area where I can debug this?


For anyone else having this issue I finally figured it out on my own. the following is a simplified set of steps to convert the Oracle VM to a MS Hyper-V (if anyone needs more specific instructions, let me know:

  1. Download the Oracle VM image from ERPNext site
  2. Use StarWind V2V converter to perform the actual Image conversion
  3. Attach the new .vhdx image to your Hyper-V host
  4. Start the new VM and you’ll notice networking is DISABLED (using $lshw -C networking)
  5. Note the “logical name” from the above output
  6. Edit configuration “.yaml” for your VM using something lilel “sudo nano /etc/netplan/01-netcfg.yaml”
  7. Be sure the “ethernets” name in this file is consistent with the logical name found in step 5
  8. Once you’ve replaced the existing name, save and close the editor.
  9. Back at the terminal we need to apply the netplan file changes by using “sudo netplan try”
  10. Press the key to accept the changes.
  11. We should now be able to ping any internal or external IP
  12. Continue with the remainder of the installation process

Hope this helps others,