Nginx server not working properly (centOS 7)

I’ve installed system using sudo bash --setup-production on CentOS 7 distribution.
Instead of successful installation , pages are not rendering properly.
Please Just check screenshots that I’ve attached within the Post.

*Its working in development mode (89. * . . * :8000), but not in production mode (89. *. . . ).

hi @navdeepghai
please use this
bench build
bench clear-cache

Sagar Shiragawakar
New Indictrans Technologies Pvt Ltd.

1 Like

Hi @sagar
I’ve already tried with these options , but nothing works.bench build and bench clear cache.

I Think its problems with new nginx web server version , that is 6.2.3.
Actually this version of nginx setting up all the configuration differently. its configuration does not match with our other configuration that we are using on other CentOS and Ubuntu Servers.

Please guide me how i can configure these settings in a new version of nginx web Server.
I’ve tried everything. Also try to transform nginx configuration into Apache , but it also din’t work.

output of sudo netstat -ntlp
0* LISTEN 2225/node
0* LISTEN 2229/redis-server 1
0* LISTEN 2397/nginx: master
0* LISTEN 2228/redis-server 1
0* LISTEN 2232/python // Pages are rendering correctly in Development Mode.
0*** LISTEN 2233/redis-server 1


Can you show uname -a and nginx --version outputs? The thing is that the latest version of nginx is 1.11, while you mentioned 6.2.3, which is weird.

nginx -v (output)
nginx Version is :1.6.3 ( Sorry as i prefix nginx version with 6. ) , But actual version of nginx is 1.6.3 and
uname -a (output)
Linux navdeep 3.10.0-327.22.2.el7.x86_64 #1 SMP Thu Jun 23 17:05:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux.

Thanks for responding and correcting me @strixaluco .


Maybe. . .

chmod o+rx /home/frappe
service nginx restart


thanks so much @claily

Worked for Me.