No Login Box after installation

I have installed latest version of erpnext using easy install script on CentOS 7 on Google Cloud.

Installation process completes without any error, But when you go to the front end, there is no login box shown.

Can not login, can not configure apps and modules.So stuck in the beginning.

It is a totally fresh install, I even tried with ubuntu 14 and Debian 7 too, same result.

There is only header and footer shown without any login box to enter login detail.I tried a number of similar troubleshoot guides but in no vain.

Kindly suggest.

Hi @shardaatul04,

there is most probably something wrong with building your JS. When you open the browser console, you should be able to observe some error like “… is not a function”.
This is a current issue that already has several threads. It basically boils down to the integration of the new package manager yarn. Try the following:


$ bench build

and observe the errors. Typically, there are some issues like Update error: Cannot babelify - Unknown plugin "transform-object-rest-spread"


$ sudo npm install -g yarn
$ sudo bench update

If bench build still fails, install the mentioned missing dependencies (npm install (...) )

Hope this helps.