No "New" Button in doctype Patient

Hello everyone! any idea how to add patients here. there is no new button appeared. Thank you so much for your help

Go to Role Permission Manager and search for Patient doctype. Check the Roles that have access to the patient doctype as shown below.

Check which of these roles have been assigned to you. Once that is done, make sure those roles have the “Create” checkbox checked to allow the role to create a new patient.

If not, contact your System Manager to do the needful.

Hope this helps.

1 Like

Thanks :slight_smile:

Doesn’t set the Permission when creating doctype enough to allow a role to create?
And is this role addition also required for Administrator?


It should be there by default for most of the roles. However, sometimes do due changes done manually, this checkbox can get unintentionally unchecked. Hence, it is always better to first have a look at the Role Permissions Manager to see if there is a problem with the permissions.

Hope this helps.