Not able to solve the issue for nginx while installing

not able to solve the issue for ngnix while installing the frappe with this command:
sudo python --production

and getting the following error:

TASK [nginx : Ensure nginx is started and enabled to start at boot.] ****************************************************************************
fatal: [localhost]: FAILED! => {“changed”: false, “msg”: “Unable to start service nginx: Job for nginx.service failed because the control process exited with error code.\nSee "systemctl status nginx.service" and "journalctl -xe" for details.\n”}

RUNNING HANDLER [mariadb : restart mysql] *******************************************************************************************************

RUNNING HANDLER [nginx : restart nginx] *********************************************************************************************************
to retry, use: --limit @/tmp/.bench/playbooks/site.retry

PLAY RECAP **************************************************************************************************************************************
localhost : ok=49 changed=10 unreachable=0 failed=1

Traceback (most recent call last):
File “”, line 425, in
File “”, line 122, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 338, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/”, line 190, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2

I have tried the commands for reloading the ngnix and tried uninstall and installing the ngnix…still this error is not solve.

Can anyone please help me?

Thanks in advance!

You may have had an already running copy of nginx/apache2 which would have “stolen” the port 80/443, and therefore the nginx installation fails

What is the solution then??

If it were me, I’d uninstall apache2 and nginx, and then run the install. Once that finishes, you can reinstall apache2 (if you need it)

Thanks alot!!!
It worked for me.