Notifications Not Working With Workflow

Hello everyone,

I created a custom workflow for my quotation doctype and that works perfectly. I also have a custom Notification that should send a notification when a quotation is submitted. I have tried entering in a condition such as “doc.workflow_state == “Pending””, but that hasn’t worked at all.

When I disable the workflow, the notification works without any issues, but when I activate the workflow, the notifications stop.

Here are some screenshots if it helps:



Any help would be appreciated.

I also raised this issue where custom notifications do not work unless you enable email alerts and then both the standard workflow alerts and the custom notifications are sent thus confusing your intentions. So far i haven’t received any response.

So for my issue, I actually figured out the solution. I just changed the “Doc Status” in my Workflows so that Approved = 1. After this the notifications started appearing again

Here’s a screenshot if it helps:


This probably is because - in the notification settings you have set “Send alert On → Submit”.
If you change it to “Send alert On → Save”, then you need not to set the ‘DocStatus’ in workflow as ‘1’