Only logo after login of a fresh installation

I Just installed the last version of the erpnext (develop branch)on a new virtual machine with Ubuntu 16.

The process went well but i have a problem. when i open the default page on port 8000 i see the login form, and i can log in succefully, then the application is redirected to /desk but i can only see the logo in the center of the page and i have theese errors in chrome console

Uncaught SyntaxError: Unexpected token <<
capture.js:14 Uncaught TypeError: Cannot set property 'get_data_uri' of undefined
    at capture.js:14
    at social_factory.js:21
(anonymous) @ capture.js:14
(anonymous) @ social_factory.js:21
list_factory.js:7 Uncaught TypeError: Class extends value undefined is not a constructor or null
    at list_factory.js:7
    at interaction.js:350
(anonymous) @ list_factory.js:7
(anonymous) @ interaction.js:350
formview.js:6 Uncaught TypeError: Class extends value undefined is not a constructor or null
    at formview.js:6
    at success_action.js:93
(anonymous) @ formview.js:6
(anonymous) @ success_action.js:93
capture.js:14 Uncaught TypeError: Cannot set property 'get_data_uri' of undefined
    at capture.js:14
    at multicheck.js:163
(anonymous) @ capture.js:14
(anonymous) @ multicheck.js:163
report_factory.js:4 Uncaught TypeError: Class extends value undefined is not a constructor or null
    at report_factory.js:4
    at grid_report.js:856
(anonymous) @ report_factory.js:4
(anonymous) @ grid_report.js:856
conf.js:49 Uncaught TypeError: Cannot read property 'preferred' of undefined
    at conf.js:49
    at hub_factory.js:53
(anonymous) @ conf.js:49
(anonymous) @ hub_factory.js:53
router.js:51 Uncaught TypeError: Cannot read property 'show' of undefined
    at HTMLDocument.frappe.route (router.js:51)
    at i (jquery.min.js:2)
    at Object.fireWith [as resolveWith] (jquery.min.js:2)
    at Function.ready (jquery.min.js:2)
    at HTMLDocument.J (jquery.min.js:2)

can you help me?

1 Like

hello ,
try a bench build and bench restart, thanks.

Hello Bharat, thank you for your answer, i tried bench build and bench start (not restart because it is not automatically started at the moment) but the problem is the same :frowning:


I was just about to post the same issue! In my case however, it’s a production install. I just created a new bench (there’s already an existing bench) and installed a fresh site in that bench

In addition to the bench build and restart commands, I’ve also tried bench watch but it seems to be getting stuck at the point of rebuilding item-dashboard as shown below:

Rollup Watcher Started

Rebuilding frappe-web.css
Rebuilding chat.js
Rebuilding frappe-web.min.js
Rebuilding control.min.js
Rebuilding dialog.min.js
Rebuilding desk.min.css
Rebuilding frappe-rtl.css
Rebuilding desk.min.js
Rebuilding module.min.css
Rebuilding form.min.css
Rebuilding form.min.js
(node:3864) Warning: Possible EventEmitter memory leak detected. 11 change listeners added. Use emitter.setMaxListeners() to increase limit
Rebuilding list.min.css
Rebuilding list.min.js
Rebuilding report.min.css
Rebuilding report.min.js
Rebuilding web_form.min.js
Rebuilding web_form.css
Rebuilding print_format_v3.min.js
Rebuilding email.css
Rebuilding social.min.js
Rebuilding erpnext.css
Rebuilding marketplace.css
Rebuilding erpnext-web.min.js
Rebuilding erpnext-web.css
Rebuilding marketplace.min.js
Rebuilding erpnext.min.js
Rebuilding item-dashboard.min.js

Any help would be greatly appreciated

Kind regards,

1 Like

Okay, so it appears thinking you’re on the master branch doesn’t actually mean you are! :smiley:

I checked the git folders and realised I was on the develop branch. Switched to master and everything works fine so I guess the issue actually pertains to the develop branch


This is an issue in the staging branch too!

Need help asap!

For those on v11, they can revert to previous working commit by running (at your own risk),

cd frappe/frappe-bench # or your bench path
cd apps/frappe && git fetch upstream && git checkout 4bf32f4ff2985393ac124f589014673878152e25 && cd -
bench build
bench restart`


This is your friendly neighborhood “me too”. Staging is broken. :confused:
Hopefully will get fixed soon, or tomorrow will be a holiday :wink:

Oh, and Azhar_Islam’s fix indeed restores ERPNext to working condition.

using master, dies wit this error

Installing erpnext...
Updating DocTypes for erpnext       : [=====================                   ]Traceback (most recent call last):
  File "/usr/lib/python2.7/", line 174, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/", line 72, in _run_code
    exec code in run_globals
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/utils/", line 97, in <module>
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/utils/", line 18, in main
  File "/home/emanuele/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 764, in __call__
    return self.main(*args, **kwargs)
  File "/home/emanuele/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 717, in main
    rv = self.invoke(ctx)
  File "/home/emanuele/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 1137, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/emanuele/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 1137, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/emanuele/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 956, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/home/emanuele/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 555, in invoke
    return callback(*args, **kwargs)
  File "/home/emanuele/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 17, in new_func
    return f(get_current_context(), *args, **kwargs)
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/commands/", line 25, in _func
    ret = f(frappe._dict(ctx.obj), *args, **kwargs)
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/commands/", line 166, in install_app
    _install_app(app, verbose=context.verbose)
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/", line 85, in install_app
    sync_for(name, force=True, sync_everything=True, verbose=verbose, reset_permissions=True)
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/model/", line 56, in sync_for
    reset_permissions=reset_permissions, for_sync=True)
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/modules/", line 65, in import_file_by_path
    ignore_version=ignore_version, reset_permissions=reset_permissions)
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/modules/", line 133, in import_doc
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/model/", line 248, in insert
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/model/", line 915, in run_post_save_methods
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/model/", line 780, in run_method
    out = Document.hook(fn)(self, *args, **kwargs)
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/model/", line 1058, in composer
    return composed(self, method, *args, **kwargs)
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/model/", line 1041, in runner
    add_to_return_value(self, fn(self, *args, **kwargs))
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/model/", line 774, in <lambda>
    fn = lambda self, *args, **kwargs: getattr(self, method)(*args, **kwargs)
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/core/doctype/doctype/", line 275, in on_update
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/core/doctype/doctype/", line 342, in run_module_method
    module = load_doctype_module(, self.module)
  File "/home/emanuele/frappe-bench/apps/frappe/frappe/modules/", line 186, in load_doctype_module
    raise ImportError('Module import failed for {0} ({1})'.format(doctype, module_name + ' Error: ' + str(e)))
ImportError: Module import failed for Delivery Trip (erpnext.stock.doctype.delivery_trip.delivery_trip Error: No module named google_maps.google_maps)

after using this fix, I could no longer do a bench update

It fails with:
"subprocess.CalledProcessError: Command ‘basename $(git symbolic-ref -q HEAD)’ returned non-zero exit status 1

…however git checkout staging returned things to normal.

i did some tests, and succefully installed the master (v10) and staging (v11) versions of erpnext, the main problems occur in development (v12) version