Package mariadb-server-10.3 is not available

When I run this:
sudo apt install mariadb-server-10.3
I get an error saying:

Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Package mariadb-server-10.3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
mariadb-server-core-10.6 mariadb-server-10.6

Can I use 10.6 or the latest 10.9.1 RC ,or how can I get 10.3 now?
Thank you!!

Short answer: You can definitely use the 10.6 it mentioned. It’s fine.

Every Linux distribution + version offers a different set of software. To discover what the Advanced Packaging Tool (APT) offers on a Debian-based system, type this in a console:

sudo apt-cache search "mariadb-server"

For example, my laptop (Debian 11) replies with this:

mariadb-server - MariaDB database server (metapackage depending on the latest version)
mariadb-server-10.5 - MariaDB database server binaries
mariadb-server-core-10.5 - MariaDB database core server files

So I could install MariaDB Server 10.5 using 'apt

Without using 'apt', you can install any version you want. There are many ways. If you want binaries, the links for MariaDB are here:

Warning: If you’ve never done this before, know that installing MariaDB manually does -not- yield identical results, compared to installing with ‘apt’. Package Managers usually do extra, helpful things during installation. For example configuring the SQL “root” account, loading Time Zones, creating a directory structure. Sometimes they alter the 'my.cnf' file.

If you’re in a hurry, I would stick with ‘apt’, rather than potentially get “stuck” manually installing.

But if you have time to experiment, it’s quite possible: I’ve manually installed MariaDB several times.

Another great way to get a specific version of MariaDB server is with Docker. Just have to make sure you configure the Database data files to be persistent.

Thank you very much.
Some article says we should use scripts after install mariaDB:

USE mysql;
UPDATE user SET plugin=’ ’ WHERE user =‘root’;

But after 10.3, TABLE user CHANGED TO VIEW user,
And we can’t update a view.
That’s why I want to install 10.3.
Do you know how to change the script?
Thank you again!

I’ve never needed to run that particular statement. But I know a forum user that has…

Hi @bkm!
See question above. You were asking the same question last week: what happens if you skip the “plugin” statement? (because it doesn’t work anymore after 10.3)

Did everything work out okay for you, when you skipped that step?

1 Like

Hi again,

It seems to have worked, although I have not had the time this week to put it through a thorough test sequence. I do have a sandbox server running with this configuration and the few cursory tests seemed to have worked out well.

Do I endorse it as the fix? Well, all I can say is that:

  • The install didn’t blow up
  • The Admin startup wizard ran just fine
  • The database restore of one of my production servers didn’t blow up
  • Creating a Sales Invoice seemed to work.

That is all I have had time to test. So I would say to anyone else that it is certainly worth a try.

BKM :sunglasses: