Permissions issue after update


It’s me again.

Other of the issues I have after a recent update to V5, is that my user can’t see icons on the dashboard when logging in to ERPNext.

The other user of the system does not have this problem, and if I duplicate my user, the new user can see the icons also without problems.

I thought it was a permissions issue, but maybe not?! Sometimes I see the nice colour background empty with no icons, but just after login I see the nav bar with completely white screen beneath, with no icons.

If a search the modules on the search bar I don’t have any problem in accessing all the modules and documents.

I tried to reset permissions from command line, but this is what I get:

/home/erpnext/frappe-bench/apps/erpnext/erpnext/accounts/doctype/chart_of_accounts/chart_of_accounts.json missing
Traceback (most recent call last):
  File "/usr/lib/python2.7/", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/", line 72, in _run_code
    exec code in run_globals
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/utils/", line 77, in <module>
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/utils/", line 14, in main
  File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 610, in __call__
    return self.main(*args, **kwargs)
  File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 590, in main
    rv = self.invoke(ctx)
  File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 936, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 936, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 782, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/", line 416, in invoke
    return callback(*args, **kwargs)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 28, in _func
    ret = f(frappe._dict(ctx.obj), *args, **kwargs)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 381, in reset_perms
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 288, in reset_perms
    "DocType", doctype, force=True)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 515, in reload_doc
    return frappe.modules.reload_doc(module, dt, dn, force=force)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/modules/", line 37, in reload_doc
    return import_files(module, dt, dn, force=force)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/modules/", line 17, in import_files
    return import_file(module, dt, dn, force=force)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/modules/", line 22, in import_file
    ret = import_file_by_path(path, force)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/modules/", line 54, in import_file_by_path
    import_doc(doc, force=force, data_import=data_import)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/modules/", line 120, in import_doc
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/model/", line 183, in insert
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/model/", line 518, in run_post_save_methods
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/model/", line 466, in run_method
    return Document.hook(fn)(self, *args, **kwargs)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/model/", line 577, in composer
    return composed(self, method, *args, **kwargs)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/model/", line 560, in runner
    add_to_return_value(self, fn(self, *args, **kwargs))
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/model/", line 460, in <lambda>
    fn = lambda self, *args, **kwargs: getattr(self, method)(*args, **kwargs)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/core/doctype/doctype/", line 115, in on_update
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/core/doctype/doctype/", line 124, in run_module_method
    getattr(module, method)()
  File "/home/erpnext/frappe-bench/apps/erpnext/erpnext/crm/doctype/newsletter_list_subscriber/", line 13, in after_doctype_insert
    frappe.db.add_unique("Newsletter List Subscriber", ("name", "email"))
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 739, in add_unique
    add unique `%s`(%s)""" % (doctype, constraint_name, ", ".join(fields)))
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/", line 140, in sql
  File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/", line 205, in execute
    self.errorhandler(self, exc, value)
  File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
_mysql_exceptions.OperationalError: (1061, "Duplicate key name 'unique_name_email'")

Many thanks for your kind help and your time, as always

Fixed the issue. Please try updating again.

Hi Nabinhait,

Many thanks for your reply.

I have just migrated again from v4, and I can’t see the icons.

Should I try the bench reset-perms again?

Thanks and kind regards,


Well, I tried with bench reset-perms, and it is still blank the dashboard.

Also, it complained with a couple of missing files:

server:~/frappe-bench$ bench reset-perms
/home/erpnext/frappe-bench/apps/erpnext/erpnext/accounts/doctype/chart_of_accounts/chart_of_accounts.json missing
/home/erpnext/frappe-bench/apps/frappe/frappe/website/doctype/style_settings/style_settings.json missing

It is not a permission issue. I have fixed the issue, please try after updating.

Deleted those 2 deprecated doctypes via patch


I am still missing the icons in here after updating and deleting caches.

Many thanks Nabinhait for your help and kind regards,


Icons recovered after last update today at early afternoon.

Many thanks and kind regards from Spain!

Hi. We fixed the icon issue yesterday. Can you update again?

Hi Anand,

Yes, I updated yesterday and it is working great.

Many thanks!!