Pip install fails for custom app

Error code 1 is defined in errno.h and means Operation not permitted. Try this

pip install --upgrade setuptools

Requirement already up-to-date

try using older version of PIP by -
./env/bin/pip install --upgrade pip==9.0.3

and try again.

ohk i am trying

same error…

try removing -q and check/share the exact error -

./env/bin/pip install -e ./apps/spanapp --no-cache-dir

What’s your pip version? You can figure this out by executing/typing pip --version in the command line.

If it’s version 10 and above, try pip install --force-reinstall pip==9.0.3 to bring it back version 9.0.3.

pip 9.0.3 from /home/satish/span/local/lib/python2.7/site-packages (python 2.7)

Can you try executing :

./env/bin/pip install -e ./apps/spanapp

and then posting the error traceback here? Removing -q from the command should show the error that’s preventing you from installing your app.

I had the same issue and the problem was in setup.py
The setup.py in my custom app was different from the ones in default apps life frappe and erpnext, on the latest develop branch. So customized my setup.py to look exactly like the one in frappe and it worked