Please add the account to root level Company V11.1.15

I get above message when I try to edit any detail on an account. The company has a parent company. But the parent’s CoA is not editable and cannot add the account to the root level company


I’m having the same issue

My temporally workaround was to set the parent_company field to null directly from mariadb console

1 Like

Thanks for sharing!

Same here v11.1.17

would you mind to share the SQL command?

Here you are

update tabCompany set parent_company='';

Make a backup first, you never know :grinning:


This also helped me:

update tabCompany set allow_account_creation_against_child_company=1;

It restored the ability to add child account from the UI

1 Like

Worked for me as well, thanks!

Getting error while updating mariadb database through console.

You are using safe update mode and you tried to update a table without a WHERE that uses a KEY column

You can bypass this by adding AND name != '' at the end of your where clause

Thanks for your quick response. It is working now.

MariaDB [_***********]> update tabCompany set allow_account_creation_against_child_company=1 where name != ‘’;
Query OK, 3 rows affected (0.065 sec)
Rows matched: 3 Changed: 3 Warnings: 0

Hi Friends ,

I am using version ERPNext: v11.1.38 (master) and have found a solution/ workaround for this issue without getting to DB level

The scenario is as follows

1 Company is created and saved
2 Edit company and try and create tax template
the error shown is Please add the account to root level Company -
The solution is as follows;
3First edit the company field "Allow Account creation against child company’ to checked (True) , the default value would be Unchecked {False)
4 Edit company and try and create tax template

Cheers !!