POS Print Format rate field without currency


Which field to be use instead of “rate” to print without currency (symbol)?

currently using <td class="text-right">{{ item.get_formatted("rate") }}</td>

try ti use {{ item.rate }}

1 Like


Try this.

<td class="text-right">{{ item.rate }}</td>

1 Like

Oh, That works perfectly Thanks a lot…

1 Like

While printing one zero is coming after decimal



I can’t really understand what you trying to ask.

i am doing customisation in Quotation Print Format . Added HTML code in Items section instead of dragging the Items table. Below mentioned the code. I don’t want currency in columns i tried the code as below

{%- for row in doc.items -%}
            <td style="width: 3%;">{{ row.idx }}</td>
            <td style="width: 20%;">
                {{ row.item_name }}
                {% if row.item_code != row.item_name -%}
                <br>Item Code: {{ row.item_code}}
                {%- endif %}
            <td style="width: 37%;">
                <div style="border: 0px;">{{ row.description }}</div></td>
            <td style="width: 10%; text-align: right;">{{ row.qty }} </td>
            <td style="width: 15%; text-align: right;">{{
            <td style="width: 15%; text-align: right;">{{
        {%- endfor -%}
ID Material Description Quantity (PCS) Rate(AED) Amount(AED)

Any help??

How many decimals are set in Currency Precision in System settings?

Please the below @fkardame

Select the decimals u need dear. In UAE you should use 2 decimal precision.

Ok , i did that

Needyour help @fkardame

i used this below code in cheque printing to Omit Currency AED, but when it Comes in print ,for example 1456.50 , it displays only 1456.5 , zero is not displaying

{{doc.base_paid_amount or doc.base_received_amount}}

Bump up.

Am using EPSON ESC/POS RAW Format. Rate and Amount fields are not showing currency symbol correctly (they appear as upside down question marks).

Here’s the raw print format sample code:

{%- for i in range (1,16) -%}
{%- set row = doc.items[i-1] -%}
{%- if row != null -%}
{{ ‘\x09’ + row.get_formatted(“rate”, doc).rjust(15) }}
{%- else -%}
{{ ‘\x09’ + ’ ’ + ‘\x0D’ + ‘\x0A’ }}
{%- endif -%}
{%- endfor -%}

Anyone know how to issue the “row…” command to get the field unformatted? I tried rate.doc it gives me an error that states it has to be string not integer. Please help. Much thanks!