POS Printing - Stopped! - No pages found! error

I have been trying to print a POS Invoice on a thermal printer for sometime now but I have been unsuccessful. For testing purposes I have installed ERPNext on a Linux machine successfully.

The error message I get from the CUPS admin page is stopped! - No pages found!

The test page on the thermal printer prints successfully.

This issue revolves around how ERPNext tells the CUPS server to print the POS invoice, if there was a way the server would be told to explicitly send a text/html overriding the mime.types lookup directly from the webpage with the printer then the problem would be solved.

Any ideas how I can resolve this issue?

SOLVED: use the Chromium Web Browser.

@kariuki pull-request ?

No need… Solved - Chrome is the de-facto web browser, we can close this.

@kariuki I meant can you share your solution if its generic enough? Maybe other users can use it too.

@rmehta Yeah, Sure… you mean post it in GIT? - already offered a solution above… when the firefox or iceweseal browser does not print a POS Invoice use the Chrome browser.

I meant if there is any connector you built for thermal printers.

For Chrome it was seamless… worked with minor modifications, I’m still working on Firefox/Icewesel … I still have to get the hang of loading a production or development setup without the errors.