Postgresql with Frappe

Hello Community Member,

I have created a new site with POSTGRESQL. this site only have frappe app with administrator user.

The problem is, i’m not able to login into the site. I tried to reset admin password and Password was updated successfully but still the same issue.

Below method i used to install frappe,

  1. bench init frappe-bench
  2. bench new-site dev --db-type postgres
  3. bench install-app frappe
  4. bench start

No issue with installation.

Thanks in Advance


how? how you resolved it?

It was rectified with migration.

Can you maybe give some learning insight here?

For example this sounds like fun

1 Like

The difference between the two migrations.
What @Sahil seems to be doing is a heart / brain replacement.
What I am doing is blood transfusion. (Data is the new blood) :slight_smile:
Mine is a bit easier.


@Not_a_countant You love to use organs as metaphors. In the other post you compared process to skin a cat and here do blood transfusion. Should have been a doctor :grinning:

1 Like

Still i see the same problem with postgres, tried with migration and build command

@Sahil, it is not resolved, if u know any steps, please reply here

Same issue here: installed fine. What creds do I use to login? Tried a ‘bench migrate’ in another window and got:

Migrating dev
mariadb service is not running.
Cannot run bench migrate without the services running.

but I only run Postgres.


User as Administrator. Make a Capital.


It worked - awesome thanks. Might want to put that somewhere on the login screen. Cheers, Dave