Pre-installed Virtual Box Image network issue

Hi Guys,

I’m having issue when trying to run my newly installed image, on browser.

When I checked the VM setting, its set to NAT(I tried bridging too, but didn’t work).

when I ran the ifconfig command it showed loop back IP.

Can you elaborate as to what exactly is the error.
Are you not able to access ERPNext in the browser?


Attached is the screenshot… there is no ip binding by default I believe

There is binding by default. May I ask when you downloaded the image? Because I just downloaded the Production Image and its working just fine.
Are you using the Production Image or the Development one? Also mention your host OS.


I downloaded production from erpnext website, using windows 10 as base machine

Okay please try this:
Right Click on the Image and click on Settings,
Click on Network,
Click on Advanced,
Click on Port Forwarding,
And check if you have the row which specifies the following:

| Name  | Protocol | Host Port | Guest Port |
|vm_http| TCP      | 8080      | 80         |
1 Like


**Its working now on virtual box, previously I was using vm workstation **

It would be better to document the actual ports that are open for people who run it as a bridge instead of NAT mode, rather than frustrating new people who don’t know why the ports the software tells them to browse to don’t work.

@Joshua_Bowman Hmmm, good idea, will do it soon


I am also facing the same issue.

There’s nothing wrong with the image. I can confirm that re-downloading the image won’t fix the issue.

It’s something that has changed in Ubuntu 16.

I have tried both NAT and Bridged network. Nothing helped.

I did some searching on the net and found that many other people are facing the same issue.

However, none of the provided solutions worked for me.

Any help on this regards will be greatly appreciated.

Thanks and regards,

If this is your issue, maybe setup a serial console to get access to the VM? Then you can run dhclient to assign an IP address to gain ssh access? virtualbox serial console · GitHub

Hi @clarkej

That is not exactly my issue. I am running ERPNext on my Win 7 PC using VMware Workstation 12. I can access the console without any problem. However, that VM can’t seem to be able to access the network. I have tried both NAT and Bridged. But no joy.

If it do ifconfig, I get only the loopback adapter “lo” listed. However, ifconfig -a discovers my physical network “ens32”.

I went through all aforementioned solutions and nothing worked.


If you followed best advice steps but have no clue why not the expected outcome, and dmesg and any logs shed no light

And despite the problem apparently is 16.04 network interface config, maybe switch from Win 7 OS host + VMware - for eg the original poster reported success with VB…

Hi @clarkej

Thanks for your reply.

To be honest, I am pretty new to Linux (I know that it’s a shame. But…). Hence, not really sure what I am doing.

I have tried VBox and it works there out of the box. But not with VMWare. However, ERPNext 9 which is on Ubuntu 14 works on both VBox and VMware.

I installed Ubuntu 16 on new VMware machine from the scratch. Didn’t have any network issue there. I then tried to setup ERPNext there using “Easy install” method. But the setup didn’t complete successfully.

I am insisting on using VMware, because, I am planning to host ERPNext on a ESXI 6.5 system.

Additionally, I have tried to update an already working version 9 installation on ESXI 6.5 using bench update. After completion of the process, I simply can’t login using the browser.

Any help will be greatly appreciated.


My thoughts -

So you have some success with 16.04 networking. Why not use the working one to troubleshoot why the network config does not work on the ERPNext host, that will require learning Linux however.

Yes easy-install and/or updates often do pose a problem, but none that can’t be readily resolved with help from this forum.

You may want to stay current with advances and fixes; support for V9 will grow unpopular and not voluntary.

BTW for me KVM works problem free. I use snapshots but have you to master merging blocks, internal snapshots and other depths.

Hi @clarkej,

Thanks a ton for pointing me in the right direction.

Finally, I have found the solution. Following are the steps for Linux noobs like me.

  1. Open terminal
  2. type ifconfig -a and press enter
  3. Make a note of the ethernet interface. In my case it was ens32
  4. Type sudo vi /etc/network/interfaces and press enter
  5. Press i
  6. Locate the line # The primary network interface
  7. Comment out everything henceforth by appending a # at the beginning of each line.
  8. Then add new line as below,

auto ens32
iface ens32 inet dhcp

Note: replace ens32 with the interface name you have found in step 2.
9. Press Esc.
10. Press :w to save
11. Press :q to quit
12. Type sudo /etc/init.d/networking restart and press enter.
13. Issue ifconfig to see if it worked.

@clarkej, your support is what made me more interested in Linux. Thanks a lot. I will come back with more questions if you don’t mind.

Kind regards,

1 Like

Well done your followup notes will benefit all - and to start a new thread would be ideal thanks!