Prepared Report for Stock Balance is taking days to Complete

I have a project in production and for two days now, generating Stock Balance (a Prepared Report) has been really slow. It spends an entire day in Queue before going into Completion.
I have checked for similar issues on the Forum, but no actual answers. I have also read the documentation to see if I’ll find anything useful for cases like this, but nothing. I have also checked to ensure that the schedulers are working correctly.

What can I do?

Do you have huge number of transactions? What are the from_date and to_date filters?
Also, share your system specs and number of workers.

We use K8s so resources are dynamic. However, we have a worker resource memory limit of 2Gi.
Also, from_date is 2022-09-26 and to_date is 2022-10-26 (just one month)

Check your background jobs list and see if the queue is big. If yes, try to investigate why it is happening.

A temporary solution would be to increase the number of workers, again, that depends upon the number of cores your CPU has.

Similar problem here. Increasing the number of workers didn’t help
The log files don’t provide useful information

I have seen similar topics on the forum but remain unsolved

Did you check the background job list?

Ideally, this is how it would look when things are working properly.

Yes, I did. That’s exactly how it looks

This is after you have tried to generate Stock Balance Report?

Yes please

If the list is empty after you clicked Generate New Report, either it ran successfully or failed. Click on the Show Failed Jobs button on top to see if it’s in the failed job list. If not, then it ran successfully and Prepared Report document must show completed.

I am also having the same problem. The background jobs list is empty same as above, and the report is in a queued status

@rtdany10 this is the exact issue.

Can you make sure redis is running?
Also please show the output of bench doctor

Redis server is running

Bench doctor output

-----Checking scheduler status-----
Workers online: 3

After updating and rebooting the server it is working again.

This was what fixed it for you?

Yes. I think it has something to do with NGINX.
Becuase during the update NGINX was also updated.