Preparing Report popup message but report is not generated

Hello people,

I have customized the stock balance report but here report is not getting generated sometimes. It gives a popup message like “Preparing Report” for too long time and report is not displayed.
Sometimes it will generate the report. May i know what was the problem here and to overcome from this issue.


Hi @Nivedha,

I think you should remove the Preparing Report option because sometimes reports have long data and then take time.

If you want to remove Preparing Report then please go the the Role Permission for Page and Report and then select the report.

If checked option in Disable Prepared Report then remove it.

Then reload (Ctrl + Shift + R) and check it.

Thank You!

Hi @NCP, thanks for your response. I tried but no change

@Nivedha in V15, if your report is “Custom Report” it’s by default a Prepared Report. frappe/frappe/desk/ at 82d723b73fbff041d907e4be46d7450426aa47f8 · frappe/frappe · GitHub

I still do not know why this approach because it was working fine before.

Hi @Nivedha,

If the Setwise Stock Balance report is made from Stock Balance then you should follow the step which I provide. Please set the Stock Balance report and check it.

Thank You!