Print Designer help

I have updated to version 15 frappe and ERPNext app.

I wanted to install the Print Design so I can design the invoices. It happened that I need to upgrade. I did that, re provisioned the SSL secure Let’s Encrypt, it is all done.
I followed the GitHub Instructions how to install the print designer. It downloaded the app in the bench directory, then I installed it on the site which is in production mode.
The next step requires me to access the web-based setup on port 8000
I cannot for God’s sake access it, I have opened all the ports on all firewalls (external public server firewall ad UFW firewall) I have even tried to setup a VPN connection straight to the server to skip the firewalls. Nothing works.

See now I went to check the ports, they seem open and there is some kind of unicorn listening on that port, I am assuming its the web setup.

Did the bench version -f table
| App | Version | Branch | Commit |
| erpnext | 15.20.2 | version-15 | 7711b13 |
| frappe | 15.21.0 | version-15 | cbb96c8 |
| nextcloud_integration | 0.0.1 | main | bdfda11 |
| payments | 0.0.1 | develop | aed6e9d |
| pibical | 0.0.1 | version-13 | a5dedb0 |
| print_designer | 1.0.0 | develop | 08a6285 |

Why is the print designer in develop version?
So now I am trying to remove it and re-install it in production mode.
No resources how to remove this app. when I try bench uninstall-app print-designer
Could not find app “print-designer”:
No module named ‘print-designer’ … long list of error codes.

Please help

Please check the image because you used a dash (-), whereas you should use an underscore (_).

That seems to do, thank you so much for replying I am truly grateful !

But now when I do
bench uninstall-app print_designer
Uninstalling App print_designer from Site
All doctypes (including custom), modules related to this app will be deleted. Are you sure you want to continue? [y/N]:

Well, not sure, this seems frightening, doesn’t it?

I am trying now in the meantime
bench --site install-app print_designer
App print_designer already installed

If you uninstall the app, all related doctypes, custom fields, and other data associated with the Print Designer app will be deleted.

After uninstalling the app, you should first migrate the site and then verify the changes.

Not sure if I am interpreting this the correct way.
I understand that removing the app would delete actual data in the database, along with potential modules this app is tied with. That is not what we want on a production server :frowning:

Well, decided to go ahead and spin the wheel of fortune.

This is the output:
bench uninstall-app print_designer
Uninstalling App print_designer from Site
All doctypes (including custom), modules related to this app will be deleted. Are you sure you want to continue? [y/N]: Y
Backing up…
Deleting Module ‘Print Designer’

  • removing Module Def ‘Print Designer’…
    Uninstalled App print_designer from Site

I have followed the steps from GitHub:
bench --site install-app print_designer

Installing print_designer…
Updating DocTypes for print_designer: [========================================] 100%
Updating Dashboard for print_designer

Same problem, can’t access it on port 8000
I’ve allowed TCP and UDP on both firewalls. There is nothing else listening on those ports.
What is happening? I cannot imagine what is going on…

Moving forward, yeah, I’ll build myself a little test environment before deploying into production, yeah I shoulda done that before… I figured tho DB is backed up every six hours, exported, so even if everything went south, I can re-deploy.

@denny369v you don’t have to access it on port 8000. it is just example which is using default port 8000 that development server runs on when you do bench start. you can access it normally from desk like this

1 Like

Holy smokes it worked idk how but it loaded I assume since I removed the old one which somehow got confused with develop… what the heck. IT WORKS now guys awesome deal I am grateful sir