Print format: currency symbol not shown

Hi there,

i’m experiencing a couple of problems:

  • Currency symbol is not showing in print format even if field type is Currency:

in print form:

Try with another browser.
I had a same issue with chrome but worked with Mozilla browser.

@satisharalkar tested with Chrome and Safari, same problem

Is it a custom print format? if yes, use doc.get_formatted("field_name")

1 Like

@saurabh6790 i’m not using custom format, should I?

@saurabh6790 Hi there, i used custom html:

{{ doc.get_formatted("total_sales") }}

but currency symbol doesn’t appear in print view.

Any hint?

what is field type for total_sales ? to have currency symbol field type should be currency.

@saurabh6790 yup, it’s currency …you can see in first image

Hi @JoEz

For parent field use
{{ doc.get_formatted(“field_name”) }}

While for child field use
{{ row.get_formatted(“field_name”, doc) }}

For more details please check, POS Invoice print format

@rohit_w it’s not working neither using:

{{ doc.get_formatted("field_name") }}

it seems to be working for date only

it seems parent field needs {{ doc.get_formatted("field_name", doc) }} to apply format correctly i’ll double check …

Any updates in this issue ?

set field option to Company:company:default_currency

{{ doc.get_formatted(“field_name”) }}