Print option is working if (ctrl+p) hit, but its not visible

I have created a new role called “assistant” and in “roles permission manager” i have given access to print. technically when ctrl+p is hit it brings the print page, but its not visible in the menu, your support is highly appreciated

in below screenshot its not visible

when ctrl+p is hit then its working fine

the below is the role permision

please check, if any client script applies for the print option. if applied then remove it.

We tested the same thing with only one role, and it worked properly. again check the user role is applied proper or not.

@NCP I followed your instruction and disabled all my client scripts but it was still the same so i tried several things and found out that in the ROLE doctype when unticking the SIDE BAR checkbox, it will hide the sidebar plus (the icons of PRINT, < and >" also hiding all of the options inside the menu as below screenshot


i want to also hide the sidebar and everything in the menu except UNDO, REDO :cry:

@NCP Is there any other way to hide sidebar without affecting on hiding print button its neighbor buttons?